We're updating the issue view to help you get more done. 

Optimize Stage dependencies

Description

  1. Update Webpack from v1 to v3/v4 - more efficient, up-to-date (Webpack migration and webpack-3-react-production-build-tips)

  2. Update ReactJS from v15 to v16 - it's smaller and faster

  3. Clear warnings in `npm install`:

    1 2 3 4 5 npm WARN schema-utils@0.4.3 requires a peer of webpack@^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself. npm WARN uglifyjs-webpack-plugin@1.1.6 requires a peer of webpack@^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself. npm WARN cloudify-ui-new@4.4.0--.dev1 No license field. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

Status

Assignee

Jakub Niezgoda

Reporter

Jakub Niezgoda

Labels

Target Version

4.4

QA Owner

Lital Hamami

Premium Only

no

Documentation Required

No

Why Blocked?

None

Release Notes

no

Priority

None

Sprint

None

Priority

Unprioritized