Status reporter update request fails slow

Description

When the reporter try to send the report to a failed manager it takes more than 30 seconds for it to fail.
In the meanwhile this node considered to be in Fail state.

As we can see in the reporter log:
```
30/12/2019 15:08:17 [DEBUG] [status-reporter] Before _report_status
30/12/2019 15:08:51 [DEBUG] [status-reporter] Error had occurred while trying to report status: HTTPSConnectionPool(host='172.17.0.2', port=53333): Max retries exceeded with url: /api/v3.1/cluster-status/db/ce6fbb5f-f625-4a3e-9883-1ec87767e36d (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f8979d18610>: Failed to establish a new connection: [Errno 113] No route to host',))
An error occurred when trying to connect to the manager,please make sure it is online and all required ports are open.
This can also happen when the manager is not working with SSL, but the client does
30/12/2019 15:08:51 [DEBUG] [status-reporter] Before _report_status
30/12/2019 15:08:51 [DEBUG] [status-reporter] Sent a status report to 172.17.0.3:
```

Steps to Reproduce

Environment:
OS (CLI), HA cluster, cloud provider
------------------------------------

Steps to reproduce:
------------------
1.
2.
3.

Expected result:
---------------

Actual result:
-------------

Why Propose Close?

None

Assignee

Inbal Amrani

Reporter

Inbal Amrani

Labels

None

Severity

Medium

Target Version

5.0.5

Premium Only

no

Found In Version

5.0

QA Owner

None

Bug Type

new feature bug

Customer Encountered

No

Customer Name

None

Release Notes

yes

Priority

None

Priority

Blocker
Configure