Timeout waiting for deployment environment creation

Description

One of the jenkins tests had a timeout waiting for deployment environment creation:

This was on jenkins: /job/dir_system-tests/job/system-tests-premium-multi-network/898/consoleFull

I can't see anything else obvious in that section of the logs.

Steps to Reproduce

-

Why Propose Close?

None

Activity

Show:
geokala
December 17, 2019, 12:15 PM

Error repeated on second run, I’m trying to repro with pdb enabled now.

geokala
December 17, 2019, 12:54 PM

We restart rabbitmq just before we try to install the deployment. This causes problems communicating with the queue service and leaves the deployment env creation stuck. This is a problem with the test, not with cloudify.

geokala
December 17, 2019, 2:11 PM

Well, that wasn’t an accurate assessment.

The recent restore status Jira introduced a bug where an extra command was tacked onto the end of post-restore commands without a semicolon or space.
This caused the mgmtworker token not to be regenerated.
This meant that the mgmtworker never actually successfully restarted to the point where it was logging to file (hence the misleading log files).

A PR is now up to fix this.

geokala
December 17, 2019, 3:51 PM

Multi-net tests now passing.

Assignee

geokala

Reporter

geokala

Labels

None

Severity

Medium

Target Version

5.0.5

Premium Only

no

Found In Version

5.0

QA Owner

None

Bug Type

unknown

Customer Encountered

No

Customer Name

None

Release Notes

no

Priority

None

Epic Link

Priority

Blocker
Configure