Allow linking a blueprint to the latest plugin version installed on the manager.

Description

Currently the blueprints can only reference yaml.plugin that point to a specific version of a plugin. And so, in deployment time the process fails if the plugin in this specific version is not available (not in the tenant/as a global plugin), even if the same Iaas plugin in a newer version does exist and available.

We need to allow specifying a generic plugin.yaml in the blueprint without a version (for example "openstack" and not "openstack 2.5" , in which case the the latest version available will be taken.

Status

Assignee

Omer Duskin

Reporter

Talia Sela

Labels

None

Severity

None

Bug Type

None

Target Version

None

Severity

None

Sprint

None

Fix versions