We're updating the issue view to help you get more done. 

Upgrade cryptography version in cloudify-premium's venv

Description

We install signxml==2.4.0, which pulls in cryptography <1.10 and pyOpenSSL <18. This ends up installing pyOpenSSL 17.5.0 and cryptography 1.9, which aren't actually compatible. We need to upgrade signxml to 2.5.2, which will start pulling in cryptography 2.1.4, which is compatible with pyOpenSSL 17.5.0

Status

Assignee

Łukasz Maksymczuk

Reporter

Łukasz Maksymczuk

Labels

None

Severity

None

Bug Type

None

Target Version

None

Severity

None

Fix versions